You are here

CM/ECF Compatible Browsers

The current list for system requirements with the latest version of CM/ECF are listed below.  This page will be updated as needed. 

  • Internet Explorer 11
  • Edge 84.0.522.40 - 85.0.564.51
  • Firefox 78.0.2 - 80.0.1
  • Chrome 84.0.4147.89 - 85.0.4183.102

NOTE: Safari is supported but was not tested in release 1.6 due to constraints imposed by the COVID-19 pandemic.

 

updated 7/20/21